• This section is "bound" to the Resources page. Once you've submitted a new mod to the resources, a new discussion about your mod will be automatically generated and posted in this section. That means, you can't create a new thread by hand in here.
WorldEdit

WorldEdit 0.3.2.2

No permission to download

Ciaran

Stone
Messages
3
Reaction score
0
Damn okay, nah I'll pass on doing that and just believe you :p Thanks anyway.
 
OP
mampf

mampf

Administrator
Admin
Mod Dev
Messages
104
Reaction score
67
WorldEdit uses the Serializer which is delivered by Eco itself.
Currently there is no editor and afaik it's not possible to edit the file.

If you're programmer and you're interested in the file structure feel free to contact me in discord or via private message ;)
 

Thecowboy09

Stone
Messages
3
Reaction score
0
So, I recently put this on a server, thought I did everything correctly. Files are in the Mods folder. Server boots fine. I use the //wand command, which populates an icon on my action bar. All that being said, the minute I select the wand I go flying across the map and either crash the client or get stuck in the ground somewhere. It should be noted I'm not actually controlling my avatar either. I know I'm missing something, and can't seem to find a reference to this issue on the forums. So can you tell me what I'm doing wrong?
 

PapaHarni

Stone
Messages
11
Reaction score
1
So, I recently put this on a server, thought I did everything correctly. Files are in the Mods folder. Server boots fine. I use the //wand command, which populates an icon on my action bar. All that being said, the minute I select the wand I go flying across the map and either crash the client or get stuck in the ground somewhere. It should be noted I'm not actually controlling my avatar either. I know I'm missing something, and can't seem to find a reference to this issue on the forums. So can you tell me what I'm doing wrong?
U have updated the server to 0.7.5.0 ;-) I have the same problem. ;-)
 

Gabeux

Coal
Mod Dev
Messages
33
Reaction score
27
For those wondering, it does work with 7.6, I copy and pasted a whole huge Companion Cube with it. :) Even the Undo function works better than I remember in 7.4.

One thing I that didn't seem to work was the shift command, but maybe I was doing things wrong.
I haven't tested all available features though.
Thanks mampf!
 
OP
mampf

mampf

Administrator
Admin
Mod Dev
Messages
104
Reaction score
67
Hello ;)

I did a small test and everything worked for me with 0.7.7.1

mampf
 

Sekoris

Stone
Messages
12
Reaction score
1
1536531359821.png


When i import a schematic in 0.7.7.1
Post automatically merged:

 
OP
mampf

mampf

Administrator
Admin
Mod Dev
Messages
104
Reaction score
67
Hello ;)

Thanks for reporting the issue. I can not reproduce it. =(

Can you send me the broken schematic?

Best regards Mampf
 
OP
mampf

mampf

Administrator
Admin
Mod Dev
Messages
104
Reaction score
67
Hello ;)

Thanks for the file. I see - the schematic is completely crap.. =(
I think I must reimplement the schematic format...

Thanks for the report. I hope I have some time next week :p

Regards mampf
 
OP
mampf

mampf

Administrator
Admin
Mod Dev
Messages
104
Reaction score
67
Hello ;)

I played a little bit around and I still can not reproduce this issue.
Does this error came from all imports or only when you import a specific region?

I think there is somewhere a item which causes this issue. So when you import and export a single grass block everything is working?

Can you send me your whole server and the coordinates which you want to export?
 

PapaHarni

Stone
Messages
11
Reaction score
1
Which issue u mean? Wand tool item or Import the file? I have test all schematic files there i have. Thats only 5 files but no one work.

I don't want export anything ;-) Only import this one House of the file. But now i have rebuild it and u can trash the schematic file ;-) I will test it when i have finished the build with export and than import. ;-)

Thanks 4 the Work ;-)
 
Top Bottom